Roof Wizard - Version 8.2
Enhancements List

ENHANCEMENTS

Version 8.2 sees the improvement of specifying
Shingles and Shakes in the AppliCad software.
A new Set-Up dialog has been designed to
allow entries of information more specific to
Shingles and Shakes, as well as an improved
method of application through the Cover >
Select-Shingle and Select-Shake menu options.
As can be seen from this dialog, many of the
features specific to Shingles and Shakes have
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specifies the storey and 22.5 specifies the pitch have had to
create multiple mappings for each pitch gradient in 0.1
degree increments. In 8.2, we have provided the ability for

Cancel

each pitch interval to be given as a label (e.g. A, B, C as can be seen in the attached image) with the
output therefore being Ridge (1,A), or Ridge (1,B) etc. This greatly reduced the number of mappings
required, thus reducing the workload for our users and speeding up the interface between systems.

In 8.2, we have provided Web Licensing

Roof Wizard - License Informatien - Web Licensed

Online Payment

(Automatically generated by your computer) Viit Applicad.com

of the Roof Wizard software as standard. | o ..., p [NoazszanezzovrvwzzE7 (Suppled to you by AppiCad)
All users with internet access will =T 24120 {Supplied to you by Applicad)

therefore be able to utilise as many ComputerID | 750668

licenses as they have available to their InstanceID  [228% (The instance of the software running)

System Info

organisation, concurrently, from any
location. This flexible licensing will work
for all our users who have previously had
to contact AppliCad to check licenses out
when travelling or taking annual leave.

L Roof-Wizard
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ppliCad

The new licensing also provides improved

End User License Agreement

accessibility of the software to all users in
your organisation, thus ensuring the right
tools are provided to the right resources

Software Products covered by this EULA

at the right time. Roof Wizard

RoofScape

END-USER. LICENSE AGREEMENT (EULA) FOR JR Systems Software (AppliCad)

IMPORTAMNT-READ CAREFULLY: This JR Systems End-User License Agreement (EULAT) is a
legal agreement between you (gither an individual or a single entity) and JR Systems for the
software product(s) identified above which may indude associated media, printed materials, and v
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In 8.2 we've been working hard on ensuring the software is as easy to use as possible, for such a
comprehensive estimating solution. For our most comprehensive dialog, Track-Outline, we’ve provided
More and Less buttons to hide the less used functions of the software until you need them. This cleans

Wall Direction and Distance
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the interface up
and provides a
simple user
experience for
first-time users.

We've done the same for the Mod-Roof > Dormer dialog. The options can be seen here:

Dormer Defaults

Type of Dormer Gable -
Pitch 30.00

Hole Defaults

== | 1
Setback From [Tn @
Dormer Width 6900.00 Mo
| 1

2650.00 ﬂ ®

Zoom Fit |

Front Overhang

=

Preview

Cancel

X Dormer Defaults

Type of Dormer fozble] -
Fitch 0.0 =]

Hole Defaults

Distance to Edge 0.00 ﬂ [
Setback From ~1430.00 ﬂ ®
Dormer Width £500.00 ﬂ ©

Side Length 0.00 Mo

Emmiil
I

Front Overhang

Side Overhang

The Mod-Roof > Advanced > Cut-Out function has been
enhanced to allow for the automatic specification of a
rectangular cut-out shape of a given area. Once the user
has entered the required area, they can then specify
whether the rectangular shape area should be calculated
on the roof pitch or the flat. Once ok is selected, the
user then simply drags the rectangle shape over the
required roof plane and the rectangle orients itself on

L)
L)
[Mem -]
Eave Type [FascmGutter <]

Gap Width

Gap Offset to Eave

Side Style

Darmer Material

Insert at Apex ‘

Draw Side Walls of Dormer W~

Insert along Hip ‘

7 Help Lessa

Zoom Fit | Preview

Cancel ‘ oK

Cutout Defaults

Rectangular frea

Select the Planes by

Canicel

Define the Cutout Area by

Keep or Delete Pieces ?

Rectangular Area

17.50 m2  Piched

| |Jzing the Yizible Flanes

=]

Delete the Intemal Pieces |

?

that roof plane based on the roof pitch. Function keys F1 to F4 can be used to make the rectangle wider
or higher, depending on the requirements.
This function is going to be of considerable benefit to solar tile specifiers who can calculate an area of a

roof to place solar tiles within and have the area maintained and changed to Shingle or Shake plane type
so that solar tiles can be estimated at the same time as normal tiles.

Modified Attach-Plane defaults to allow depth to be specified. This allows
roof planes to be attached to existing planes (such as for a pitch-change
modification) with the depth of the new plane being specified rather than

the eave height, as previously.

Attach Plane Defaults x

Fioof Type Metal -
—
20.00 J
2400.00 J

i

Starey
Pitch

Plane Depth
Cancel
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In versions of Roof Wizard prior to 8.2, the Zone Infrastructure
functionality was contained within the Cover > Flashings dialog
and access to it only appeared when the user had defined Zones
and applied them to the roof. As such, few customers bothered as
they were not aware of the additional functionality provided by

the Zone Infrastructure dialog.

This functionality has been moved to the Zone dialog, thus
ensuring customers utilising the zone functionality have a single
location to apply all the additional linework they need when
setting up zones. Great for re-roofing over the top of an existing

roof.

Zone Options X
Zone Widths T =
. Insert Corner Zones
Eave 914.40
2. Insert Field Zones
Ridge 603.60 ;
3. Insert Edge Zones
Hip 304.80 #
Split Zone Planes
Valley 0.00
Merge Zone Planes
Gable 0.00 #
Modify Zone Edges
Apron 0.00 #
Delete Edge Zones
Other 0.00 #
Delete Field Zones
Delete Corner Zones
Delete Selected Zones
Delete Hole
Insert Infrastructure Lines | ? Cancel ‘

We’ve made some substantial improvements to our Block Cutting code:
o Extending the edge of a block now turns off all other roof lines, making edge lines of blocks much

easier to select.

o Roof planes now maintain their transparency when coming back from Mod-Blocks or Move

Existing Block.

o Block Cut plane edge lines now use the same colour for the plane as the plane edges, thus

ensuring plane edges are never hard to see.

o Fixed crash caused by selecting an already-assigned plane for a block.
o Added Undo and Redo to placement of legend so undoing this action is much simpler than

previously.

o Added option to turn on or off Block Planes and also to allow definition of blocks in Block-Cutting
by selecting a Block-Cut plane (remaining) rather than a roof plane. F1 performs this task.

o Turned off flashing information for when printing the Block Cut drawing.

o Added a check to make sure user wants to delete all Block-Cut planes if option is selected. This

saves having to re-do a lot of work.

o Ensured that when going to Modify-Blocks the block-cut planes are turned on.

Flashing Assemblies in Version 8.2 have been given
a further boost by the inclusion of rules for
flashing assembly parts that can now be
performed on a per-piece basis. Various assembly
items can be included, or left out, based on these
rules being applied. An example might be to allow
for a certain type of fastener if the roof being
applied is a of a given material type, or to change
the fastener for another roof material. Very
powerful for our customers wishing to apply
complex rules to their flashing assemblies. We've
also added an “Add Blank” command to allow
assemblies to be quickly built with the fast
insertion of flashings, accessories and fasteners
and then the product codes can be entered
manually later.

Assembly Manager

Assembly Group | Vertical Seam (Str)_16_ACG_22.0_Open Steel Frame

| modfyen ‘

Eave (Fixed) ~
Eave with Offset Cleat (Floating)
Encinall with Counter Flashing (Floating)
Endiwall with Reglet Flashing (Floating)
Expansion Joint

Extended Eave (Floating)

peak (Fixed)

Peak (Floating)

Rake (Fixed)

Rake (Floating)

Rakewall with Counter Fiashing (Floating)
Rakewall with Reglet Flashing (Floating)
Slope Change {Fixed LS)

Slope Change (Fixed HS)

SSR Hip (Floating)

SR Ridge (Floating)

Transition

Valley ith Offset Cleat (Floating)

valey (Fixed)

Vented Ridge (Floatine
FE ﬂ_i’& b
v

Assemblies

MocifyNew

& POF

C:\Appicad_Data_MSMC\: J

(" Database/Figure [ Vertical Seam.dab J

11inch Hip (Floating) J

Assembly Type [ Ridge Fiashings | Nominal Assembly Length | 10-00
Product Code | Description [ oty component Type [ tndude [ Rule [
5700241 11™ Ridge Hip Cover 1.00 Flashing/Trim  Rule  IF Finish = ACG
53002 11™ Ridge Hip Cover 1.00 Flashing/Trim  Rule  IF Finish = PVDF
4923640 48" Back-Up Channel 5.00 Accessory Rule IF Substrate = Open Framing
5770241 Vertical Seam Z-Closure 3.00 Flashing/Trim Rule IF Finish = ACG
58702 Vertical Seam Z-Closure 3.00 Flashing/Trim Rule IF Finish = PVDF

PH Drillr 1*
Dekfast 4°

PHWS 1° 60.00
Pop Rivet 1/8™ 30.00
Pop Rivet 1/8 30.00
Double Bead Tape Sealant 160
Tube Sealant 10.3 oz. Acyiic Clear 0.10
Tube Sealant 10.3 oz, Acryiic Clear 0.80
Tube Sealant 10.3 oz. Acrylic Clear 0.18

8242100
8241706
8243100
8240901
82409

6403899
6402800
6402300
6402800

60.00
60.00

Fastener
Fastener
Fastener
Fastener
Fastener

Accessory

Accessory

Accessory

Accessory

Add Blank Add Fiashing Add Accessory

Rule
Rule
Rule
Rule
Rule
Always
Rule
Rule
Rule

IF Substrate = Open Framing
IF Substrate = Metal Decking
IF Substrate = Wood Deck
IF Finish = ACG

IF Finish = PYDF

IF Substrate = Open Framing

IF Substrate = Metal Dedking
IF Substrate = Wood Deck

AddFastener_|

Product Code Rules




ooiizad vesens2 () AppliCad

The Gable Roof function has been improved to allow the direction Gable Roof Defaults X
of the Gable Roof to be reversed. The benefit of this is for the User Roof Type Metal g

to be able to specify the Pitches and Spans on either side of the line Storey -
inserted, with the direction being specified by the Ridge Start and Pitch Left 35.00 [zl

End locations. A line identifying the Ridge Start and End are now e R [
clearly identified on the screen also. sfpen Lo 200 ol

Span Right 4000.00 ]
Left Eave Height  |3500.00 =
rRldge Start =hmlge End Length ’71 TR f

Swap Dir | ak |
2]

Cancel

In Version 8.1, we rolled out the ###Rooflmage key text string in our reports to allow users to turn on and
off what they wanted to appear in their Microsoft® Word™ and Excel™ reports. As soon as we had done
this and released 8.1, we had a groundswell of support to provide the same for Wall reports. So, we’ve
included ###Walllmage in version 8.2, with the following capabilities:

1 — Display the Wall Plane Shading (1 = On, 0 = Off)

2 — Display Wall Panels (2 = On, 0 = Off);

4 — Display the Wall Dimensions (4 = On, 0 = Off)

8 — Display the Wall Line Types (8 = On, 0 = Off)

16 — Display Flashing Annotation (16 = On, 0 = Off)

32 — Display Wall Battens/Purlins (32 = On, 0 = Off)

64 — Display Wall Section Details (Reserved for Later Use)

128 — Display Wall Plane Areas (128 = On, 0 = Off)

256 — Display Overall Dimensions (Reserved for Later Use)

512 — Display Automated Wall Plane Labels (512 = On, 0 = Off)

1024 - Display Automated Wall Plane Labels including Windows & Doors (1024 = On, 0 = Off)

2048 - Display Automated Window & Door Labels Only (2048 = On, 0 = Off)

Wall planes can now have their areas dimensioned, by selecting the Dimension Area tool under the Check
Icon menu.

Addition of User-Defined CAD and Microsoft®
Word™ and Excel™ reports into the Roof

Wizard software has been made much e Drawings

simpler by the inclusion of an Add/Edit button SEEEEEE Eithnfrta Eist:hgf )

on the Tools > Edit-Templates dialog. ?nzéatﬁ:;aaz%ﬁim: Siﬁ'i%%%ﬁt

The new functionality permits the user to 1 bfine Report >
enter the name of the new report as they’d u

like to see it appear in the software and then Ul ReportName | Test Report

search for the template file matching this 5 Template FiefFigure | Test Report.OC] | Figure |
report. Options are provided for Drawings u " Report (Print from Quote Dialog)

and Reports to be specified, as well as for the y " Drawing (Print from Reporting > Drawings)
searching of Word™ and Excel™ templates or " - =
CAD figures within RoofWiz.DAB. 2ok | cancel

Add/Edit Delete j Cancel QK
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Added New Tech Machinery output format for their new NTM100
rollformer controller. This allows Roof Wizard and New Tech

Machinery customers to output cuttling lists directly to the onsite
rollformer, thus greatly reducing the time it takes to produce panels g “TM‘““

for installation on site.

New Tech Machinery

A MAZZELLA COMPANY

Changed the function of drop-down combo boxes within Roof Wizard so that double-clicking on a drop-
down combo box automatically drops the list down for selection by the user. Once a selection is made,
the cell of the dialog automatically closes, in the same way that selecting the <TAB> key did previously.
This improvement speeds up the data entry and will make entry of new items, such as Extras, much
faster.

Added new options to the Set-Up > Preference Settings > System-Preferences dialog that will greatly
improve the speed, configuration and usability of the software for a number of users. The new switches
perform the following functions:

o Allow the display or hiding of on-screen tooltip hints (on by default)

Hide On-Screen Command Hinks Ma

o Allow the software to search the “Corporate Folder” prior to the “User Folder” when looking for
databases, models, CSV files etc. This function will allow the user to copy a number of “Corporate
Default Settings” to the Corporate folder and by setting this switch to Yes, will ensure these
options are found by the software before being located in the User folder. Thus, Corporate
Standards will be able to be maintained more easily while still allowing other settings to be set by
the user.

Rewverze User/Corporate Folder Search Mo

o Added option to "Copy DABS Locally" which will result in database files being copied to the local
machine before being read by the software. This switch can improve database read and write
speeds across slow WAN and LAN networks.

Copy Databaze Locally before Open Mo

o The “Use Interval Labels for Labour” allows the output of labels set up under Set-Up > Metal/Tile
Pay Rates Variable > Intervals to be displayed in the Labour dialog of the Costing > Supply&Install
dialog and also to be output in the GRIM file exported.

Idze Interval Labels for Labour Yes

Added ability to space battens/purlins from top down, rather than the bottom up. This option is provided
on the Batten Spacing dialog and

Batten Spacings x

Interval Spacing from Eaves

Closestto Eave Second Clasest 0.00 Third Closest .00

Intermediate Spacing

Fived Gpacing 500,00 From Eave Up
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e Added new coloured icons to the Roof Wizard software to make the icon menu easier f\ s
to understand and faster to load. Icons are now only searched for in the AppliCad -
Programs folder and given that this is always a local folder, they should be much faster

to load and render than previously when they may have been read over a thin LAN or Job Info
WAN connection.
e
e Added a new Line Style definition dialog in 8.2 that not only allows for much easier Construct

modification of line styles, but also permits line styles (dashed styles) and line weights
(thicknesses) to be modified en-masse. We've also augmented the colour selection ﬂ
dialog to include a “Define” option that allows you to create your own colours via Mod-Roof
selection of a Windows palette dialog.
Set Line Styles X I

MName [ Line Function [ colour Style Weight | ShowAngle |~ a Is

Ridge RIDGE 0 0.50 X

Valley VALLEY 1 0.50 %

Hip HIP 0 0.50 X

Fascia-Gutter FASCIA | 2 0.50 N/A

Gable GABLE 0 0.50

Fascia-Barge FASCIABARGE  ESIM O 0.50

Fascia-Only FASCIA-ONLY Bl 0.50

Gutter-Only GUTTER-ONLY B o Color «

Barge-Orly BARGE-ONLY 0

Angle Apran APRON 0 Basic colors

et e, M W EECEEE

tee E EFTEEEEN

er el P, (NEEEEE N

Batten 2 BATTEN2 0 ENEEEEEN 4

Change of Fitch USER1 1 EEEEEEEN

e S AEEEEE T

User4 USER4 1

Drawing Entity Drawing Entity B Custom colors:

e e “-_ ; rrrrrrrnr e[ Red[TT7

Wall-Base WALL-BASE 0 ,_ ,_ ,_ ,_ ,_ ,_ ’_ ’_ ,ﬂ_ W

Wal-Top WALL-TOP 0 sat e

Wall-Corner WALL-CORNER 0 ‘ ColoriSolid )y [1217 Blue:[140°

o eoveo e 0 ] e sidotonion__|

Window-Edge WINDOW-EDGE 0 .50

Door-Head DOOR-HEAD 0 0.50

Mame Edee nAnn cnec T n nen “

Note : To Delete a Line Style, select the Item and press <DEL > on the keyboard.

? Help| Preview | SetStyles | Setwgts 1 Cancel

An additional improvement to the Set-Line-Styles dialog is the “Show Angle” option
that permits the display of a “bend angle” for flashings generated. If, for instance, the
user were to set the flag for “Show Angle” for the RIDGE line function, then these lines
will display the obtuse angle between roof planes, thus identifying the bend angle for

flashing manufacturers.

Gable Length m

Fascia-Barge Length m

Angle Apron Lengthm

Batten 1Length m

Batten 2 Length m

Box-Gutter Length m

Square Apron Length m

Change of Pitch m

Parapetm

Boundary Flashing m

User4m

Shell Ends 4.00 4.00
Hip Apexes 2.00 2.00
Barge Apexes

Rarne Ton Tntermal

Summary of Roof Quantities X
Display QuantibesFor  [Combined =]  Show UnTalied
Function [ Frst | Second | Total [Show =
Roof Volume cum 487.40 578.55 106595 ...
Roof Area sqm 426.98 478.66 905.64 ...
Curve Quality Area sqm
Ridge Length m 0.83 0.52 1.35
ManoRidge Length m
Hip Length m 57.30 61.19 11845 ...
valley Length m
Fasda-Gutter Length m 80.14 84.84 16498 ...
Gutter-Orly Length m
Fasda-Only Length m

v
>

?Help|Exporth5|Expcrtcsu| print Chg‘LType| oK

e Added a new scroll-based Display Tally dialog that permits
the display of all existing Line Lengths and Areas as per the
previous dialog, but in a much more compact format. This
new dialog allows the user to scroll effortlessly between
various stories and now includes a “Change Linetype” button
to allow the user to modify any incorrect linetypes from the
same dialog, without the need to change commands.
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A new Instructor dialog has been created for 8.2 that provides prompts
to users to assist with use of the software, as well as to highlight some
of the lesser known features of the software. The Instructor dialog is a
modeless dialog, meaning that it remains in whatever position you put
it, as long as the Roof Wizard software is open. It can, of course, be
hidden, but it is intended to remain present to lead new and existing
users through the software and provide assistance as a user progresses
through their use of the software.

All AppliCad Help has now been set to
display through our new Help Portal

AppliCad Instructor

What do you want to do?

1. Create a new roof model by going to [Construct-Roof]
and then selecting? [Track-Outline]
OR

2. Open an existing job by selecting [File > Open] from
the pulldown menu?

Learning Options

To learn mare about the Roof Wizard software, the
following opticns are available:

1. Individual dialog boxes in the software provide a Help
button, that when selected jump to the correct part of

the manual for you to read further. 9 pap

2. AppliCad Academy can be accessed by selecting Tools >
Links and choosing the Online Training option.

3. Under the Tools > Links option, a vast range of YouTube
videos can be accessed to demonstrate basic operation of
the software as well as specific addressing of some
problems.

Click here to learn more...

entitled http://help.applicad.com. This
portal will not only provide linkages < AppliCad
between the existing “?” buttons on each
dialog, but also from the link at the bottom
of the new Instructor dialog boxes. Being
online, the help files will be much easier
for AppliCad to maintain and will also
provide the benefit of additional links
being provided to YouTube videos, help
tutorials, www.roofestimating.com (our
online estimation service) and
academy.applicad.com (our online training
option).

Track Outline

&

Track Outline

Wall Direction and Distance_ IEl

Added options to snap to the end and centre of a line
using the centre mouse button. Snapping to ends of
lines was always available, but software now “jumps” to

-
T

mn]

a line endpoint to assist users in locating the pick box

Centre Button Click to Snap to Centre of Ling|

over the required point. In addition, if the user holds
down the <SHIFT> button, the option will be provided
to snap the line to another line at the centre-button
digitised location.

The display of the Status line in the software has been modified to allow for both Simple (standard) and
Complex modes. The Complex mode is a return to a previous format, as requested by some of our longer

term users who relied on information provided in this display.



http://help.applicad.com/
http://www.roofestimating.com/

oot wizad versons2 () AppliCad

e Added Undo/Redo to the Remove Cover/Annotation Delete-All dialog to prevent users losing work by
inadvertently and quickly clicking through the dialog without paying attention to what the dialog was
asking them. The Undo now allows for a simple one-click recovery of the information deleted.

e Added all available Roof Wizard Line types to Draw-Freehand option under Smart-Lines.

e Modified the Costing > Supply&Install dialog to allow for the display and modification of the Labour and
Material Mark-ups by the user. While the software still reads the default values from the Set-Up menu
options, the percentages can be changed and their totals displayed here. In addition, we have also
provided totals for each line item to the right, and a cost per unit area option for both Materials and
Labour, to assist our customers to understand their estimating pricing against the roof and wall areas.

Labour Materials Totals
Labaour SubTotal 539.86 Material SubTotal | 1759, 32 2409.18

95,98 Material MarkUp | 12.0 =y

Labour MarkUp |15-':' %o

|

212.32 | 308.30
|
|

Labour Total 735.84 Material Total | 1931.64 2717.48
Cost per m? 2.18 Material Cost per m? | 5.87 8.04

e Created a new Cover > Flashings dialog to permit the selection of flashings in a faster manner and to allow
for additional flashing types to be added in the future. A Change-Linetype button has again been added
to this dialog to allow any incorrect line types to be modified as part of the Cover > Flashings process. A
“Define Flashing” button has also been added to allow users to change flashings also as part of the Cover
> Flashing process, without the need to exit the dialog and revert to the Set-Up > Flashings option. Once
flashings are generated, fasteners are now also displayed as part of the generation of flashings, thus
allowing users to check these before getting to the Costing > Supply&Install stage.

Select/Generate Roof Batten & Trim <DEFAULT> Flashing Cutting List Summary X
Total : 152000 ~
Installer Pay Rate | Use Metal-rates j
Gutter Lysaght,Hi-Front Quad Slotted Gutter 115mm,,QGHF115%*
Battens,Purlins and Trim 15/3000
= - Total : 152000
Trim Type | Battens,Trim
N Batten 1 Stramit Battens,Mc Jones 40 mm Zinc Batten 6100 mm, Zinc,SuperLoc40
Roof Battens/Purlins 100/6 100
Batten 1 Stramit Battens  Mc Jones 40 mm Zinc Batten 6100 mm  Zinc  [Su Total : 610000
Batten 2 Stramit Battens  Mc Jones 20 mm Ceiling Batten 6100 mm  Zinc Batten 2 Stramit Battens,Mc Jones 20 mm Ceiling Batten 6100 mm, Zinc, Superloc20
100/6100
Roof Trim Total : 610000
Ridge Stramit-M] Roll TopRidge Colorbond  [RTRASSX®*¥]
) . Accessories
Hip Same as Ridge
N e MName Code Qty
\n'alle.y Sh’am!t-MJ Md:)?nald Jones Valey Colorbo.nd [CFO55%***] External Comer (50°) 0 o .00
Fasda Stramit-BR  Fasca Board Colorbond  [FBX-] Internal Corner Cap (30°) § FBICK— 4.00
0 Fascia Barge Corner LEFT () FBBCLY— 2.00
Gutter Lysaght HiFront Quad Slotted Gutter 115mm  Colorbond  [QGH Fastin Barge Corner RIGHT () FBACRY— 300
Rafter Bracket (Gal) FBVRBGA 163.52
Quad Stop End LEFT QGHF11556=* 2.00
Quad Stop End RIGHT () QGHF1155E*** 2,00
Quad Overstraps (Zinc) QGHF 11505 B87.74
Spring Clip (Zinc) NF! 110.91
Quad External Corner 20 deg {) QGHF1152PCEC™**2 10,00
Quad Internal Corner 90 deg () QGHF1152PCIC**9 4.00
EXTRA CHARGE () DELIVERY 0.08
Fasteners
MName Code Qty
Ridge M5 -11 x 65mm M51165CE 70.000
Ridge M6 -11 x 65mm MG1165CE 338,200
Valley 12x65 BHFP1265HT17 179,830
Fascia 12 -11x 40mm 121140 912,000 v
) Cancel Export CSV " Continue |
Allowances FEREEE Colour Set | Define Flashing | j
Load View List Show
4 Single Line | Set All to Mone | g g
Delete R
Generate User-ens | Delete Flashings |
Save-As =
Chag. LineType ? Help | oK | Cancel |
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e A new feature has been added to Flashing Annotation text to allow the text to be moved and this location
will be remembered when the flashing is re-generated into the future. Previously, any moved text had its
position reset by the software and this could result in a large amount of text manipulation being lost if the
user encountered any errors with the flashing annotation such that it required a re-generation.

e Added a new feature to allow the user to define the default storey for a line drawn using Draw-Freehand
under Smart-Lines.
Digitising Options X

Shap Line Angles ta

Shap Line Lengths to 10.00
Starey 2 :I

Use <CTRL> Key to Dveride Snaps when Digitizing
Right Eutton Click for Options when Digitizing

Enable Underlay Image |

Scale/Faotate |

Cancel

SMALLER ENHANCEMENTS

e Added new Project Walls option to allow walls to be projected down to a lower roof section.

e Ensured all dimensions inserted are placed on the right layer and to the appropriate colour, as specified
under Dimension Defaults.

e Fixtures now have their layers modified based on the storey of the roof they are installed on. A fixture
installed on a single storey roof will therefore be on Layer 11, with a second storey fixture on Layer 21.
This ensures fixtures turn on and off with their respective storey.

e Added Wall Batten Labour into Fixed Labour Rates dialog.

o Added ###SmallSupplyStr to display either "supply only" or "supply and installation" depending on which
dialog box the user comes from when printing.

e Added double rubber-band lines for PI-Edge-Add-Poi in Smart Lines.

e Added "Find Text" option into Tools Check command so that we can find text on panels, flashings etc.

e Unlocked remainder of all Tools > Check items for all customers.

e Added GRIM Output Folder to the System Preferences dialog.

e Changed software so that it only dimensions pitches for roof planes that are turned on. Also, doesn't try
to dimensions non-roof planes. Also modified software so that it always dimensions a pitching plane,
without the need for a horizontal line.

e Modified Extend-Barge so that a positive number is always out of the plane, and a negative number is
always into the plane.

e Modified Tools > Cha-LineType so that once you double-click on one line, you can then go and select
other lines of the same type. Command stays in the loop until finished now which makes it much faster to
use.

o Added a prompt to inform the user when all Drawings have been printed as it wasn't as obvious as it
could have been that the software had completed printing all Drawings.

e Added bolding into the header of all tables.

e Added ###FlashingTable2 key text string, providing underlined headings, removal of product code and
finish, changed PIECES to EA and rounded angle to nearest degree.

o Changed ###Ll string search to not only look for the whole category, but now to search for a substring
within the category also.
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e Modified flashing output so that it moves the flashing text by the same amount as the dimensions and
will colour the flashing text if set for dimensions also.

o Added ###SectionReport4 key text string to include section numbers.

e Modified overall dimensions so that if Zones are present, it ignores USER1-4 lines, as these may be in the
corners and could make dimensions quite overcrowded.

e Zones added to ###Rooflmagel[] as value 8192.

e Added Zone option to Change-PlaneType.

e Added a new output for RXF that includes Arcs and Ruled Surfaces. For now, this new format is entitled
Chouinard after the customer who requested the change.

e Added new option under Estimate > Allowances that allows users to turn off automatic tallying for larger
jobs or for specific panel types.

e Modified line drawing routines in the software as they are used extensively and a slightly faster option
was available.

e Added new commands to the software to improve the speed of the Solar processing.

e Added Centre alignment for tables by adding 500 to the column width specified in TableFormats.CSV.

o Modified Divide Lines functions in Smart-Lines so that you can now perform the division with the planes
left on.

e Added option to remove Z component of two points measured when you select "m" at the end of Hor,
Vert or Resultant entries for Hor/Vert command.

ISSUE RESOLUTIONS

e Ensured the </APPLICAD_EXPORT> tag was included with non-Xactimate output.

e Fixed issue reported by customer regarding tallying wall panels crashing. Was caused by too many short
sheets. Increased value to 5000.

e Added automatic removal of zero length lines from the outline for the roof track.

e Removed code added for customer as it was creating havoc with other customers with regards Barge
Flashings being included in Fascia/Barge and Gable stages.

e Removed Downpipes from plane collection function so that they don't get accidentally pitch or area
dimensioned.

e Changed reading in of Assembly Groups so that case is no longer a differentiator between product codes.

e Fixed issue where using the middle mouse button to scroll the screen while measuring a distance could
result in an incorrect distance being measured by the software when scaling.

e Fixed issue for ###SarkinglobCost and some other Sarking Key Text Strings not displaying due to category
being changed to Underlay.

e Fixed issue for CAD templates for multiple ###Ll Key Text Strings not working properly within single string
and also added in TOT, DISC, SUB for ###Ll Key Text Strings.

e Changed number of profiles that could be stored in a dialog from 100 to 200 to fix customer issue.

e Fixed interminable loop created sometimes when doing an Intersect Planes, depending on geometry.

o Added Key Text String ###CostingDetailsTable4 to include the discount amount rather than the sub-total.

e Forced closing of Word application as it seemed to keep control of the template file, thus causing a
second estimator running from the same folder to crash.

e Fixed issue with area dimensioning on curved roofs crashing.

e Fixed output of custom profiles where the length was being truncated to 25 characters.

e Fixed issue for Fascia and Gutter Internal and External corners not saving away allowances.
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e Fixed reading in of Solar Insolation TMY3 files, allowing up to 2048 character widths. Also added in a
prompt displaying that the file is reading in and displaying the line number, so user is aware of progress.

o Fixed ###Ll so that it is no longer case sensitive, as well as adding in an _COL option to output colour.
Also fixed issues for missing ###FasciaCol and ###GutterCol information.

e Fixed issue for customer where <ARCS> XML label was missing despite </ARCS> existing.

e Made sure that “panel lengths” > “max length” does not return 0 when reading next stock length. Will
only be max length from now on.

e Set dimensions to true so that pitch dimensions appear again on ###Rooflmage[16] output.

e Modified SaveAs function to repeatedly attempt and report errors if it fails to save.

e Modified Custom Flashing sizing dialog to provide a better positioning of the preview image.

e Defaulted minimum cost for Custom Profiles to the lowest value, even if it's smaller than that. This way,
we'll always get a value, rather than 0 if it's not found.

e Fixed crash in Open-Thumbnails that was caused by incorrect database name in the ThumbNI.DAT file.

e Modified Pitch dimensions to use the correct Roof Storey (16, 26 etc.) as well as the new dimension

Colour.

e Modified the Flood-Fill command so that it properly specifies the storey of the plane inserted as per the
dialog.

e Added Fixture selection into the Change-Storey option as they should now be able to have their storeys
modified.

e Removed Supplier from ###QGList, as per customer request.

e Fixed wall labour for fixed and variable rates as well as adding in Wall Batten Labour for both.

e Modified code to make Downpipe Accessories as “D Access” again, unless an alternative category is
specified.

e Added display of Quote Groups back into the QG dialog under Supply & Install.

e Modified code so that you can't select OK off the dialog box if the OK button is disabled.

e Tracked down bug found by customer where the outline wouldn't draw for some reason.

e Fixed issue with labour not tallying correctly for Sheet Accessories.

e Added new functionality ###QGList for customer to display just the elements in each Quote Group - using
Description.

e Fixed issue with accessories for Top and Bottom Corners loading multiple times when Single-Line flashings
added.

o Modified the saving of BMP images from the clipboard to JPG's so you can now zoom in almost infinitely.

e Modified Order Form printing so that we don't write out a cutting list for "Split Each run into Stock
Lengths Pieces" estimated parts.

e Changed default Scaling Option to "Whole Model & Image" rather than what is was set to previously.

o Modified code so that Nett-Rates Costing dialog remembers which rate file was selected.

e Added Auto-Save for Drawings, as per customer request.

e Fixed issue where coursing calculation for tiles, shingles and shakes wouldn't work if line types weren't
properly defined.

e Fixed issue with CustFlashRates.CSV not working properly if there weren't at least 2 values less than the
girth being searched for.

e Turned on flashing of point for "Split Plane Distance" as well as ensuring that the command doesn't
continue to split repetitively if you abort out of the question to do so.

e Added NONE into Track-Plane for re-inserting planes.

e Fixed issue where Fascia, Gutter and Gable flashings wouldn’t generate properly when selected into an
individual Stage.

e Provided additional error checking when sheet length < 0 or > 10,000,000mm.

e Fixed split of panels to put plane and text on the correct layer.

e Ensured Userl - User4 print their lengths properly on a Quantity Report as reported by customer.
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e Fixed issue reported by customer where wall waste would sometimes report as negative.

e Fixed customer issue with labour items for Downpipes not translating properly to S&I dialog.

e Fixed customer issue of line items going missing from Labour dialog when selecting Load of an existing
quote.

e Fixed issue for customer for fasteners for wall cladding using the wrong estimation method/price.

e Added in Walllmage processing code as well as modifying CAD Template processing of ###Ll_items so
that it doesn't make text all uppercase.

e Changed length inquiry within software so that wall lines dimension properly in 3D.

e Changed cropping of imagery for Word and Excel documents so that it only crops Plan View images.

o Added a brief delay into double-line clicking as sometimes it would auto-abort out of change linetype.

e Moved GRIM import so that the scale of the drawing is set AFTER the GRIM file is read in.

e Fixed issue where some planes don't produce a direction arrow for Pitches as they didn't have any flat
lines or if they did, they were very small and hard to see.

e Fixed issue for wall dimension lengths being multiplied by pitch when drawn flat. Also, allowed flat walls
to be dimensioned by area.

e Changed code for tallying and combining short sheets so that they take into account whether there is a
rounding amount. Prevents getting incorrect summing of short sheets on the Section Report.

e Fixed issue where deleting Downpipes could crash the software.

e Changed code so that you can still open files when in Read-Only mode.

e Removed auto-save of NettFlashing creation so that customer doesn't have issues with saving of
databases when using Stage Manager in Supply & Install.

e Fixed issue with ###SectionReport that caused crash.

e Removed I/f and I/m etc. suffixes from ###PanellLens etc. so that users can add them to %CALC
calculations.

e Changed ###NettQuantitiesTable strings for CAD, Word and Excel such that the software uses user
defined names for each linestyle, rather than the default as previously.

e Fixed issue with Xactimate output hanging due to hole deletion creating new plane each time.

e Fixed issue with Wall Panels not splitting correctly.

e Fixed issue where number of boxes of membrane fasteners was not rounding up but rather truncating.
So, for box sizes of 1000, if only 800 fasteners needed the value was 0, should have been 1.

e Fixed issue where output of CSV file from Tally-Quants reported Batten2 gty as Batten qty.

e Costing Plus removed.

e Changed Maximum number of Flashing Types per job up from 25 to 200. This is due to us also including
the flashing angle between roof planes now also as standard, so this increases the number of unique
flashing records per job.

e Fixed issue where planes were being drawn inside out. This manifested itself when battens were inserted
into a plane with a hole in it.

e Fixed issue where Extra Quantities were only tallying for estimation methods such as "Spaced Along
Ridge" for first storey totals, not whole roof totals.

e Changed flashing code so that the processing of individual lengths only goes through the whole list of
elements once, rather than going through the whole list each time for each line type.

e Fixed error with Measure Pitch function where one axis was still incorrect.

e Added code to read in a different version of the People File from past versions.

e Ensured that Tile Accessories with colour take on the same colour as that selected for the tile.

e Ensured if table addition in a report fails, the Key Text String gets replaced with nothing so that the
software doesn’t loop interminably.

e Added new function to determine maximum panel length in the model.

e Modified Split-Panels so that it now queries the longest panel in the job as the default value for length but
allows you to query the defined Max. Panel Length still.
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e Modified the Minimum Panel Length functionality to work properly for Combine for Minimum Lengths
and Combine for Maximum Lengths.

e Changed default for Tile Accessory Estimation method from 16 to 17 for Apex as this is where it is now.

e Changed status line redraw code so that the update of the Database/Model names ALWAYS occurs.

e Ensured text, sub-figures and circles only zoom fit if the entities themselves are visible. Used to zoom to
extents of text, for instance, whether the text was visible or not.

o Added bounds checking for when lists for metal panels go astray.

e Removed "Unable to save/restore old state of APPL/software from disk" error. Won't appear anymore
and also removed whooshy.tmp file.

e Modified code so that rotation of underlay images is 90 degrees for ISO view.

e Removed deletion of Windows Resource handle when printing as this was causing a crash after Windows
10 update when printing filled planes.

e Commented some code out of DWG writing so that it now works again, instead of crashing.

e Added check to prevent non-plane lists from crashing the software.

e Upped maximum number of strings in a scroll control from 1000 to 2500.

e Fixed issue where non-fractional inches were not working in the software.

e Removed clear function for when a database doesn't read in correctly. This allows partial database
reading rather than the whole thing being discarded.

e Fixed decimal issue where if no foot number specified, then it wouldn't work properly with the inch
fraction alone.

e Added space between feet and inch markers when no whole inches exist.




